PayPal payment issues

Incident Report for Overleaf

Resolved

PayPal payments are now operating normally.
Posted Aug 07, 2025 - 12:01 UTC

Monitoring

The issue affecting PayPal payments has been resolved. Our team will keep this incident in a monitoring state.
Posted Aug 07, 2025 - 11:03 UTC

Identified

We are currently experiencing an issue that is preventing PayPal payments from being processed. We have initiated a formal investigation request with PayPal's support team to resolve the current payment disruption. PayPal's support team has advised us that their investigation process may take 24-48 hours to complete. During this review period, PayPal payments will remain unavailable. We have confirmed that all other payment methods, such as credit card payments, are unaffected and continue to operate normally.
Posted Aug 07, 2025 - 10:03 UTC

Investigating

We are currently experiencing an issue that is preventing PayPal payments from being processed. All other payment methods, such as credit card payments, are unaffected and operating normally.
Posted Aug 07, 2025 - 08:40 UTC
This incident affected: overleaf.com (Overleaf).