Issue with project invites

Incident Report for Overleaf

Resolved

Project invitations are now working again. Incident is now resolved.
Posted Jul 09, 2026 - 17:03 UTC

Investigating

Some users may currently encounter issues while trying to accept invitations to join projects. Our teams are currently investigating.
Posted Jul 09, 2026 - 15:39 UTC