Problems logging in with newer versions of Firefox
Incident Report for Overleaf
Resolved
The issue has been resolved in reCaptcha. The login form should now work again in all browsers.
Posted May 06, 2024 - 18:36 UTC
Investigating
Some users with newer versions of Firefox are reporting problems logging in to Overleaf. After submission, the login form reports the error: "captcha check failed: challenge expired". This seems related to compatibility problems between Firefox and reCaptcha. We are currently looking for solutions. For the moment, the workaround is to use another browser.
Posted May 02, 2024 - 18:26 UTC