Some publisher submissions failing

Incident Report for Overleaf

Resolved

This incident has been resolved. All failed submissions should now have been processed, but please contact our support team if you have any questions.
Posted Mar 12, 2026 - 18:54 UTC

Monitoring

A fix has been implemented are we are monitoring the results.
Posted Mar 12, 2026 - 18:00 UTC

Investigating

Some submissions to publishers are failing to upload. The team is investigating.
Posted Mar 12, 2026 - 16:09 UTC