Editor failing to load for some users

Incident Report for Overleaf

Resolved

The site is now operating normally.
Posted Nov 05, 2025 - 15:48 UTC

Update

The site should be fully operational now. If an opened Editor page is still hanging, please refresh the page.
Posted Nov 05, 2025 - 11:11 UTC

Monitoring

Some users were unable to load the Editor page, since 9.40GMT this morning.
The problem has been identified and fixed.
Posted Nov 05, 2025 - 11:06 UTC
This incident affected: overleaf.com (Overleaf).