Dropbox syncs delayed
Incident Report for Overleaf
Resolved
The issue with delayed sync to Dropbox has been resolved
Posted Jun 23, 2022 - 12:57 UTC
Investigating
We are investigating delays in syncing with Dropbox
Posted Jun 23, 2022 - 12:41 UTC
This incident affected: overleaf.com (Overleaf).