Issue affecting subscriptions

Incident Report for Overleaf

Resolved

This incident has been resolved.
Posted Jun 05, 2025 - 14:32 UTC

Monitoring

The issue is now resolved and all subscription-related functionality should be back to normal.
Posted Jun 05, 2025 - 12:57 UTC

Investigating

We are currently facing an issue that may affect the ability of our users to subscribe or manage their subscription. Please reach out to our support team if you require assistance while we work on resolving the situation.
Posted Jun 05, 2025 - 12:29 UTC